FreeBSD : rubygems -- request hijacking vulnerability (a0089e18-fc9e-11e4-bc58-001e67150279)

Medium Nessus Plugin ID 83513


The remote FreeBSD host is missing one or more security-related updates.


Jonathan Claudius reports :

RubyGems provides the ability of a domain to direct clients to a separate host that is used to fetch gems and make API calls against.
This mechanism is implemented via DNS, specifically a SRV record
_rubygems._tcp under the original requested domain.

RubyGems did not validate the hostname returned in the SRV record before sending requests to it. This left clients open to a DNS hijack attack, whereby an attacker could return a SRV of their choosing and get the client to use it.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 83513

File Name: freebsd_pkg_a0089e18fc9e11e4bc58001e67150279.nasl

Version: $Revision: 2.3 $

Type: local

Published: 2015/05/18

Modified: 2017/07/06

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:ruby20-gems, p-cpe:/a:freebsd:freebsd:ruby21-gems, p-cpe:/a:freebsd:freebsd:ruby22-gems, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/05/17

Vulnerability Publication Date: 2015/05/14

Reference Information

CVE: CVE-2015-3900