Adobe/Apache Flex ASDoc Tool XSS

Medium Nessus Plugin ID 83475

Synopsis

The remote web server contains HTML documents that are affected by a cross-site scripting vulnerability.

Description

The remote web server contains one or more HTML documents created with an unpatched version of the Adobe/Apache Flex ASDoc tool that is potentially affected by a cross-site scripting vulnerability due to a failure to properly sanitize user input.

Solution

Update the affected files in the case of Adobe Flex. For Apache Flex, either upgrade to Apache Flex 4.14.1 or update the affected files.

See Also

https://helpx.adobe.com/security/products/flex/apsb15-08.html

https://blogs.apache.org/flex/entry/apache_flex_4_14_1

Plugin Details

Severity: Medium

ID: 83475

File Name: adobe_flex_apsb15-08.nasl

Version: 1.4

Type: remote

Published: 2015/05/14

Modified: 2018/06/27

Dependencies: 10107

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flex_sdk, cpe:/a:apache:flex

Required KB Items: Settings/ParanoidReport

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2015/04/14

Vulnerability Publication Date: 2015/04/07

Reference Information

CVE: CVE-2015-1773

BID: 73954