FreeBSD : phpMyAdmin -- XSRF and man-in-the-middle vulnerabilities (c6e31869-f99f-11e4-9f91-6805ca0b3d42)

Medium Nessus Plugin ID 83441


The remote FreeBSD host is missing a security-related update.


The phpMyAdmin development team reports :

XSRF/CSRF vulnerability in phpMyAdmin setup.

By deceiving a user to click on a crafted URL, it is possible to alter the configuration file being generated with phpMyAdmin setup.

This vulnerability only affects the configuration file generation process and does not affect the effective configuration file.
Moreover, the configuration file being generated is at risk only during the period when it's writable.

Vulnerability allowing man-in-the-middle attack on API call to GitHub.

A vulnerability in the API call to GitHub can be exploited to perform a man-in-the-middle attack.

We consider this vulnerability to be serious.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 83441

File Name: freebsd_pkg_c6e31869f99f11e49f916805ca0b3d42.nasl

Version: $Revision: 2.2 $

Type: local

Published: 2015/05/14

Modified: 2015/05/28

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:phpMyAdmin, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/05/13

Vulnerability Publication Date: 2015/05/13

Reference Information

CVE: CVE-2015-3902, CVE-2015-3903