openSUSE Security Update : libtasn1 (openSUSE-2015-360)

Critical Nessus Plugin ID 83399


The remote openSUSE host is missing a security update.


The ASN.1 parsing library libtasn1 was updated to fix one memory handling issue.

The following vulnerability was fixed :

- CVE-2015-2806: A stack-based buffer overflow in libtasn1 allowed remote attackers to have unspecified impact via unknown vectors.


Update the affected libtasn1 packages.

See Also

Plugin Details

Severity: Critical

ID: 83399

File Name: openSUSE-2015-360.nasl

Version: $Revision: 2.1 $

Type: local

Agent: unix

Published: 2015/05/13

Modified: 2015/05/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libtasn1, p-cpe:/a:novell:opensuse:libtasn1-6, p-cpe:/a:novell:opensuse:libtasn1-6-32bit, p-cpe:/a:novell:opensuse:libtasn1-6-debuginfo, p-cpe:/a:novell:opensuse:libtasn1-6-debuginfo-32bit, p-cpe:/a:novell:opensuse:libtasn1-debuginfo, p-cpe:/a:novell:opensuse:libtasn1-debugsource, p-cpe:/a:novell:opensuse:libtasn1-devel, p-cpe:/a:novell:opensuse:libtasn1-devel-32bit, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/04/28

Reference Information

CVE: CVE-2015-2806