openSUSE Security Update : gnu_parallel (openSUSE-2015-358)

Low Nessus Plugin ID 83397


The remote openSUSE host is missing a security update.


GNU parallel was updated to version 20150422 to fix one security issue, several bugs and add functionality.

The following vulnerability was fixed :

- A local attacker could make a user overwrite one of his own files with a single byte when using --compress,
--tmux, --pipe, --cat or --fifo when guessing random file names within a time window of 15 ms. [boo#928664]

In addition, the update to 20150422 adds a number of bug fixes, improvements and new features.


Update the affected gnu_parallel package.

See Also

Plugin Details

Severity: Low

ID: 83397

File Name: openSUSE-2015-358.nasl

Version: $Revision: 2.1 $

Type: local

Agent: unix

Published: 2015/05/13

Modified: 2015/05/13

Dependencies: 12634

Risk Information

Risk Factor: Low

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gnu_parallel, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2015/04/28