openSUSE Security Update : libssh (openSUSE-2015-355)

Medium Nessus Plugin ID 83394


The remote openSUSE host is missing a security update.


libssh was updated to fix one security issue.

The following vulnerability was fixed :

- CVE-2015-3146: Specially crafted packages inserted into a connection could have lead to a client or server process crash via a NULL pointer dereference.


Update the affected libssh packages.

See Also

Plugin Details

Severity: Medium

ID: 83394

File Name: openSUSE-2015-355.nasl

Version: $Revision: 2.3 $

Type: local

Agent: unix

Published: 2015/05/13

Modified: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libssh-debugsource, p-cpe:/a:novell:opensuse:libssh-devel, p-cpe:/a:novell:opensuse:libssh4, p-cpe:/a:novell:opensuse:libssh4-32bit, p-cpe:/a:novell:opensuse:libssh4-debuginfo, p-cpe:/a:novell:opensuse:libssh4-debuginfo-32bit, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/05/03

Reference Information

CVE: CVE-2015-3146