WordPress Multiple XSS

Medium Nessus Plugin ID 83351

Synopsis

The PHP application running on the remote web server is affected by multiple cross-site scripting vulnerabilities.

Description

According to its version number, the WordPress application running on the remote web server is either version 3.7.x prior to 3.7.8, 3.8.x prior to 3.8.8, 3.9.x prior to 3.9.6, 4.1.x prior to 4.1.5, or 4.2.x prior to 4.2.2. It is, therefore, potentially affected by multiple cross-site scripting vulnerabilities :

- An HTML file in the Genericons icon font package is vulnerable to a cross-site scripting attack. This package is used in various themes and plugins.

- A cross-site scripting vulnerability exists that was only partially fixed in the 4.2.1 release.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to WordPress 3.7.8 / 3.8.8 / 3.9.6 / 4.1.5 / 4.2.2 or later.

See Also

https://codex.wordpress.org/Version_3.7.8

https://codex.wordpress.org/Version_3.8.8

https://codex.wordpress.org/Version_3.9.6

https://codex.wordpress.org/Version_4.1.5

https://codex.wordpress.org/Version_4.2.2

https://wordpress.org/news/2015/05/wordpress-4-2-2/

Plugin Details

Severity: Medium

ID: 83351

File Name: wordpress_4_2_2.nasl

Version: 1.11

Type: remote

Published: 2015/05/12

Updated: 2018/08/07

Dependencies: 18297

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2015/05/06

Vulnerability Publication Date: 2015/04/27

Reference Information

CVE: CVE-2015-3440, CVE-2015-8834

BID: 74334

EDB-ID: 36844