MySQL 5.1.x < 5.7.3 SSL/TLS Downgrade MitM (BACKRONYM)

Medium Nessus Plugin ID 83347

Synopsis

The remote MySQL client library is affected by a security feature bypass vulnerability.

Description

The remote host has a version of the MySQL client library installed that is 5.1.x, 5.5.x, 5.6.x, or 5.7.x prior to 5.7.3. It is, therefore, affected by a security feature bypass vulnerability known as 'BACKRONYM' due to a failure to properly enforce the requirement of an SSL/TLS connection when the --ssl client option is used. A man-in-the-middle attacker can exploit this flaw to coerce the client to downgrade to an unencrypted connection, allowing the attacker to disclose data from the database or manipulate database queries.

Solution

Upgrade to MySQL version 5.7.3 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-3.html

http://backronym.fail/

Plugin Details

Severity: Medium

ID: 83347

File Name: mysql_5_7_3.nasl

Version: 1.9

Type: remote

Family: Databases

Published: 2015/05/12

Updated: 2018/11/15

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/12/03

Vulnerability Publication Date: 2013/12/03

Reference Information

CVE: CVE-2015-3152

BID: 74398