MySQL Enterprise Monitor < 2.3.17 Multiple Vulnerabilities

High Nessus Plugin ID 83293

Synopsis

A web application running on the remote host is affected by multiple vulnerabilities.

Description

According to its self-reported version, the MySQL Enterprise Monitor running on the remote host is affected by multiple vulnerabilities :

- A flaw exists within 'MultipartStream.java' in Apache Commons FileUpload when parsing malformed Content-Type headers. A remote attacker, using a crafted header, can exploit this to cause an infinite loop, resulting in a denial of service. (CVE-2014-0050)

- Security bypass flaws exist in the ParametersInterceptor and CookieInterceptor classes, within the included Apache Struts 2 component, which are due to a failure to properly restrict access to their getClass() methods. A remote attacker, using a crafted request, can exploit these flaws to manipulate the ClassLoader, thus allowing the execution of arbitrary code or modification of the session state. Note that vulnerabilities CVE-2014-0112 and CVE-2014-0116 occurred because the patches for CVE-2014-0094 and CVE-2014-0113, respectively, were not complete fixes. (CVE-2014-0094, CVE-2014-0112, CVE-2014-0113, CVE-2014-0116)

Solution

Upgrade to MySQL Enterprise Monitor 2.3.17 or later.

See Also

http://www.nessus.org/u?56618dc1

https://cwiki.apache.org/confluence/display/WW/S2-021

https://cwiki.apache.org/confluence/display/WW/S2-022

Plugin Details

Severity: High

ID: 83293

File Name: mysql_enterprise_monitor_2_3_17.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 2015/05/08

Updated: 2019/11/22

Dependencies: 46815

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:enterprise_monitor, cpe:/a:apache:struts, cpe:/a:apache:tomcat

Required KB Items: installed_sw/MySQL Enterprise Monitor

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/05/21

Vulnerability Publication Date: 2014/03/02

Exploitable With

Core Impact

Metasploit (Apache Struts ClassLoader Manipulation Remote Code Execution)

Reference Information

CVE: CVE-2014-0050, CVE-2014-0094, CVE-2014-0112, CVE-2014-0113, CVE-2014-0116

BID: 65400, 65999, 67064, 67081, 67218

CERT: 719225

EDB-ID: 33142, 31615