CVE-2014-0113

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

CookieInterceptor in Apache Struts before 2.3.20, when a wildcard cookiesName value is used, does not properly restrict access to the getClass method, which allows remote attackers to "manipulate" the ClassLoader and execute arbitrary code via a crafted request. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-0094.

References

http://secunia.com/advisories/59178

http://www.oracle.com/technetwork/topics/security/cpuapr2015-2365600.html

http://www.securityfocus.com/archive/1/531952/100/0/threaded

http://www-01.ibm.com/support/docview.wss?uid=swg21676706

https://cwiki.apache.org/confluence/display/WW/S2-021

Details

Source: MITRE

Published: 2014-04-29

Updated: 2019-08-12

Type: CWE-264

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:*

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
117457Apache Struts 2.x < 2.3.20 Multiple ClassLoader Manipulation Vulnerabilities (S2-021)NessusMisc.
high
83295MySQL Enterprise Monitor 3.0.x < 3.0.11 Multiple VulnerabilitiesNessusCGI abuses
high
83293MySQL Enterprise Monitor < 2.3.17 Multiple VulnerabilitiesNessusCGI abuses
high
73763Apache Struts 2 ClassLoader Manipulation Incomplete Fix for Security BypassNessusDenial of Service
high