openSUSE Security Update : wpa_supplicant (openSUSE-2015-341)

Medium Nessus Plugin ID 83230


The remote openSUSE host is missing a security update.


The wireless network encryption and authentication daemon wpa_supplicant was updated to fix a security issue.

The following vulnerability was fixed :

- CVE-2015-1863: A buffer overflow in handling SSIDs in P2P management frames allowed attackers in radio range to crash, expose memory content or potentially execute arbitrary code.


Update the affected wpa_supplicant packages.

See Also

Plugin Details

Severity: Medium

ID: 83230

File Name: openSUSE-2015-341.nasl

Version: $Revision: 2.1 $

Type: local

Agent: unix

Published: 2015/05/04

Modified: 2015/05/04

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.8

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:wpa_supplicant, p-cpe:/a:novell:opensuse:wpa_supplicant-debuginfo, p-cpe:/a:novell:opensuse:wpa_supplicant-debugsource, p-cpe:/a:novell:opensuse:wpa_supplicant-gui, p-cpe:/a:novell:opensuse:wpa_supplicant-gui-debuginfo, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/04/24

Reference Information

CVE: CVE-2015-1863