Debian DSA-3228-1 : ppp - security update

medium Nessus Plugin ID 82864
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

Emanuele Rocca discovered that ppp, a daemon implementing the Point-to-Point Protocol, was subject to a buffer overflow when communicating with a RADIUS server. This would allow unauthenticated users to cause a denial-of-service by crashing the daemon.

Solution

Upgrade the ppp packages.

For the stable distribution (wheezy), this problem has been fixed in version 2.4.5-5.1+deb7u2.

For the upcoming stable distribution (jessie) and unstable distribution (sid), this problem has been fixed in version 2.4.6-3.1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=782450

https://packages.debian.org/source/wheezy/ppp

https://www.debian.org/security/2015/dsa-3228

Plugin Details

Severity: Medium

ID: 82864

File Name: debian_DSA-3228.nasl

Version: 1.7

Type: local

Agent: unix

Published: 4/20/2015

Updated: 1/11/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ppp, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 4/16/2015

Reference Information

CVE: CVE-2015-3310

BID: 74163

DSA: 3228