openSUSE Security Update : icecast (openSUSE-2015-310)

Medium Nessus Plugin ID 82845


The remote openSUSE host is missing a security update.


The streaming server icecast was updated to fix a remote denial of service vulnerability.

A remote attacker could crash icecast and cause denial of service when URL Auth is configured and used with stream_auth without credentials (bnc#926402 CVE-2015-3026)


Update the affected icecast packages.

See Also

Plugin Details

Severity: Medium

ID: 82845

File Name: openSUSE-2015-310.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2015/04/17

Modified: 2015/05/04

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:icecast, p-cpe:/a:novell:opensuse:icecast-debuginfo, p-cpe:/a:novell:opensuse:icecast-debugsource, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/04/09

Reference Information

CVE: CVE-2015-3026