WP Super Cache Plugin for WordPress wp-cache.php Cache List Content Handling XSS

medium Nessus Plugin ID 82827


The remote web server hosts a web application that is affected by a cross-site scripting vulnerability.


The WordPress WP Super Cache Plugin hosted on the remote web server is affected by a cross-site scripting (XSS) vulnerability due to a failure to properly sanitize user-supplied input when handling cache list content in the 'wp-cache.php' script. A remote, unauthenticated attacker can exploit this issue to inject arbitrary script code within a user's browser session.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to version 1.4.3 or later.

See Also



Plugin Details

Severity: Medium

ID: 82827

File Name: wordpress_wp_super_cache_143_xss.nasl

Version: 1.6

Type: remote

Published: 4/16/2015

Updated: 1/19/2021

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: installed_sw/WordPress, www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 4/3/2015

Vulnerability Publication Date: 4/7/2015

Reference Information

BID: 73930