IBM DB2 10.5 < Fix Pack 5 Multiple DoS Vulnerabilities

Medium Nessus Plugin ID 82824

Synopsis

The remote database server is affected by multiple denial of service vulnerabilities.

Description

According to its version, the IBM DB2 10.5 server running on the remote host is affected by the following vulnerabilities :

- A remote, authenticated attacker, using a specially crafted 'ALTER TABLE' statement on an identity column, can cause a denial of service by crashing the server.
(CVE-2014-6209)

- A remote, authenticated attacker, by using multiple 'ALTER TABLE' statements that specify the same column, can cause a denial of service by crashing the server.
(CVE-2014-6210)

- An error exists in the XML library that allows a remote, authenticated attacker to cause denial of service via a crafted XML query that results in excessive CPU usage.
(CVE-2014-8901)

Solution

Apply DB2 version 10.5 Fix Pack 5 or later.

See Also

https://www-304.ibm.com/support/docview.wss?uid=swg21690787

https://www-304.ibm.com/support/docview.wss?uid=swg21690891

http://www-01.ibm.com/support/docview.wss?uid=swg21692358

Plugin Details

Severity: Medium

ID: 82824

File Name: db2_105fp5.nasl

Version: 1.6

Type: remote

Family: Databases

Published: 2015/04/16

Updated: 2018/07/06

Dependencies: 22016

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:db2

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/12/11

Vulnerability Publication Date: 2014/12/11

Reference Information

CVE: CVE-2014-6209, CVE-2014-6210, CVE-2014-8901

BID: 71729, 71730, 71734