FreeBSD : qt4-imageformats, qt4-gui, qt5-gui -- Multiple Vulnerabilities in Qt Image Format Handling (5713bfda-e27d-11e4-b2ce-5453ed2e2b49)

Medium Nessus Plugin ID 82786


The remote FreeBSD host is missing one or more security-related updates.


Richard J. Moore reports :

Due to two recent vulnerabilities identified in the built-in image format handling code, it was decided that this area required further testing to determine if further issues remained. Fuzzing using afl-fuzz located a number of issues in the handling of BMP, ICO and GIF files. The issues exposed included denial of service and buffer overflows leading to heap corruption. It is possible the latter could be used to perform remote code execution.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 82786

File Name: freebsd_pkg_5713bfdae27d11e4b2ce5453ed2e2b49.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2015/04/15

Modified: 2015/05/14

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:qt4-gui, p-cpe:/a:freebsd:freebsd:qt4-imageformats, p-cpe:/a:freebsd:freebsd:qt5-gui, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/04/14

Vulnerability Publication Date: 2015/04/12

Reference Information

CVE: CVE-2015-1858, CVE-2015-1859, CVE-2015-1860