SuSE 11.3 Security Update : libssh2_org (SAT Patch Number 10426)

Medium Nessus Plugin ID 82640


The remote SuSE 11 host is missing a security update.


The ssh client library libssh2_org was updated to fix a security issue :

- A malicious server could send a crafted SSH_MSG_KEXINIT packet, that could lead to a buffer overread and to a crash of the application using libssh2_org.


Apply SAT patch number 10426.

See Also

Plugin Details

Severity: Medium

ID: 82640

File Name: suse_11_libssh2-1-150309.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2015/04/08

Modified: 2015/04/08

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:libssh2-1, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2015/03/09

Reference Information

CVE: CVE-2015-1782