FreeBSD : osc -- shell command injection via crafted _service files (f450587b-d7bd-11e4-b5a4-14dae9d5a9d2)

High Nessus Plugin ID 82483


The remote FreeBSD host is missing a security-related update.


SUSE Security Update reports :

osc before 0.151.0 allows remote attackers to execute arbitrary commands via shell metacharacters in a _service file.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 82483

File Name: freebsd_pkg_f450587bd7bd11e4b5a414dae9d5a9d2.nasl

Version: $Revision: 1.1 $

Type: local

Published: 2015/04/01

Modified: 2015/04/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:osc, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/03/31

Vulnerability Publication Date: 2015/03/16

Reference Information

CVE: CVE-2015-0778