openSUSE Security Update : mercurial (openSUSE-2015-268)

High Nessus Plugin ID 82426


The remote openSUSE host is missing a security update.


mercurial was updated to fix a command Injection via sshpeer._validaterepo() (CVE-2014-9462, bnc#923070).


Update the affected mercurial packages.

See Also

Plugin Details

Severity: High

ID: 82426

File Name: openSUSE-2015-268.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2015/03/30

Modified: 2015/04/02

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:mercurial, p-cpe:/a:novell:opensuse:mercurial-debuginfo, p-cpe:/a:novell:opensuse:mercurial-debugsource, p-cpe:/a:novell:opensuse:mercurial-lang, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/03/20

Reference Information

CVE: CVE-2014-9462