openSUSE Security Update : libzip (openSUSE-2015-265)

High Nessus Plugin ID 82423


The remote openSUSE host is missing a security update.


Libzip was updated to fix one security issue.

A zip file with an unusually large number of entries could have caused an integer overflow leading to a write past the heap boundary, crashing the application. (CVE-2015-2331 bnc#923240)


Update the affected libzip packages.

See Also

Plugin Details

Severity: High

ID: 82423

File Name: openSUSE-2015-265.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2015/03/30

Modified: 2015/10/05

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libzip, p-cpe:/a:novell:opensuse:libzip-debuginfo, p-cpe:/a:novell:opensuse:libzip-debugsource, p-cpe:/a:novell:opensuse:libzip-devel, p-cpe:/a:novell:opensuse:libzip2, p-cpe:/a:novell:opensuse:libzip2-32bit, p-cpe:/a:novell:opensuse:libzip2-debuginfo, p-cpe:/a:novell:opensuse:libzip2-debuginfo-32bit, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/03/20

Reference Information

CVE: CVE-2015-2331