openSUSE Security Update : tor (openSUSE-2015-261)

Medium Nessus Plugin ID 82246


The remote openSUSE host is missing a security update.


Tor was updated to to fix several security issues :

The release: Contains several medium-level security fixes for relays and exit nodes and also updates the list of directory authorities.

- Directory authority updates

- relay crashes trough assertion (CVE-2015-2688)

- exit node crash through assertion under high DNS load (CVE-2015-2689)

- update geoip/geoip6 to the March 3 2015


Update the affected tor packages.

See Also

Plugin Details

Severity: Medium

ID: 82246

File Name: openSUSE-2015-261.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2015/03/26

Modified: 2015/03/26

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:tor, p-cpe:/a:novell:opensuse:tor-debuginfo, p-cpe:/a:novell:opensuse:tor-debugsource, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/03/25

Reference Information

CVE: CVE-2015-2688, CVE-2015-2689