openSUSE Security Update : libarchive (openSUSE-2015-248)

Medium Nessus Plugin ID 82012


The remote openSUSE host is missing a security update.


libarchive was updated to fix a directory traversal in the bsdcpio tool, which allowed attackers supplying crafted archives to overwrite files. (CVE-2015-2304)

Also, a integer overflow was fixed that could also overflow buffers.


Update the affected libarchive packages.

See Also

Plugin Details

Severity: Medium

ID: 82012

File Name: openSUSE-2015-248.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2015/03/24

Modified: 2015/03/24

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:bsdtar, p-cpe:/a:novell:opensuse:bsdtar-debuginfo, p-cpe:/a:novell:opensuse:libarchive-debugsource, p-cpe:/a:novell:opensuse:libarchive-devel, p-cpe:/a:novell:opensuse:libarchive13, p-cpe:/a:novell:opensuse:libarchive13-32bit, p-cpe:/a:novell:opensuse:libarchive13-debuginfo, p-cpe:/a:novell:opensuse:libarchive13-debuginfo-32bit, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/03/15

Reference Information

CVE: CVE-2013-0211, CVE-2015-2304