Fortinet FortiMail < 4.3.9 / 5.0.8 / 5.1.5 / 5.2.3 XSS

medium Nessus Plugin ID 81670

Synopsis

The remote host is affected by a cross-site scripting vulnerability.

Description

The remote host is running a version of FortiMail that is prior to 4.3.9 / 5.0.8 / 5.1.5 / 5.2.3. It is, therefore, affected by a cross-site scripting vulnerability in the web GUI due to improper input validation within the Web Action Quarantine Release feature, specifically for the 'release' parameter of '/module/releasecontrol'.
A remote attacker can exploit this to execute arbitrary HTML or script code in a user's browser session.

Solution

Upgrade to Fortinet FortiMail 4.3.9 / 5.0.8 / 5.1.5 / 5.2.3 or later.

See Also

https://fortiguard.com/psirt/FG-IR-15-005

Plugin Details

Severity: Medium

ID: 81670

File Name: fortimail_FG-IR-015-005.nasl

Version: 1.5

Type: local

Published: 3/6/2015

Updated: 1/19/2021

Risk Information

VPR

Risk Factor: Low

Score: 3

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:fortinet:fortimail

Required KB Items: Host/Fortigate/model, Host/Fortigate/version

Exploit Ease: No exploit is required

Patch Publication Date: 2/25/2015

Vulnerability Publication Date: 2/25/2015

Reference Information

CVE: CVE-2014-8617

BID: 72820