openSUSE Security Update : vsftpd (openSUSE-2015-197)

Medium Nessus Plugin ID 81623


The remote openSUSE host is missing a security update.


vsftpd was updated to fix one security issue.

This security issue was fixed :

- CVE-2015-1419: vsftpd config option deny_file was not handled correctly (bnc#915522).

Note: deny_file shouldn't be used to restrict access, as stated in the documentation. Please use more reliable methods.


Update the affected vsftpd packages.

See Also

Plugin Details

Severity: Medium

ID: 81623

File Name: openSUSE-2015-197.nasl

Version: $Revision: 1.3 $

Type: local

Agent: unix

Published: 2015/03/05

Modified: 2015/03/11

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:vsftpd, p-cpe:/a:novell:opensuse:vsftpd-debuginfo, p-cpe:/a:novell:opensuse:vsftpd-debugsource, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/02/25

Reference Information

CVE: CVE-2015-1419