Privoxy < 3.0.23 Multiple DoS Vulnerabilities

Medium Nessus Plugin ID 81516


The remote web proxy is affected by multiple denial of service vulnerabilities.


According to its self-reported version number, the version of Privoxy running on the remote host is prior to 3.0.23. It is, therefore, potentially affected by multiple denial of service vulnerabilities :

- A flaw exists in the chunked_body_is_complete() function in 'jcc.c' due to improper processing of invalid chunk-encoded bodies. A remote attacker, using a specially crafted client request, can cause the Privoxy instance to abort. (CVE-2015-1380)

- Multiple flaws exist in the pcrs_compile_replacement() function in 'pcrs.c' when handling backreferences.
Remote attackers can exploit these flaws to cause a segmentation fault or memory consumption.

- An invalid read flaw in 'parsers.c' allows a remote attacker, via an HTTP request with a specially-crafted time header, to cause a denial of service condition.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Privoxy version 3.0.23 or later.

See Also

Plugin Details

Severity: Medium

ID: 81516

File Name: privoxy_3_0_23.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Firewalls

Published: 2015/02/25

Modified: 2015/02/26

Dependencies: 65947

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:privoxy:privoxy

Required KB Items: www/Privoxy, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/01/26

Vulnerability Publication Date: 2015/01/26

Reference Information

CVE: CVE-2015-1380, CVE-2015-1381, CVE-2015-1382

BID: 72354, 72355, 72360

OSVDB: 117541, 117610, 117609