ISC BIND 9.10.2 < 9.10.2rc2 Multiple Vulnerabilities

High Nessus Plugin ID 81487

Synopsis

The remote name server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the remote installation of BIND is potentially affected by multiple vulnerabilities :

- A flaw exists within the Domain Name Service due to an error in the code used to follow delegations. A remote attacker, with a maliciously-constructed zone or query, can cause the service to issue unlimited queries, resulting in resource exhaustion. (CVE-2014-8500)

- Multiple flaws exist with GeoIP functionality. These flaws allow a remote attacker to cause a denial of service. Note that these issues only affect the 9.10.x branch. (CVE-2014-8680)

- A denial of service vulnerability exists due to an error relating to DNSSEC validation and the managed-keys feature. A remote attacker can trigger an incorrect trust-anchor management scenario in which no key is ready for use, resulting in an assertion failure and daemon crash. (CVE-2015-1349)

- An error exists related to handling the 'geoip-directory' option in named.conf when running 'rndc reconfig' or 'rndc reload' that allows connections by unintended clients.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to BIND version 9.10.2rc2 or later.

See Also

https://kb.isc.org/docs/aa-01235

https://kb.isc.org/article/AA-01246/0/BIND-9.10.2rc2-Release-Notes.html

Plugin Details

Severity: High

ID: 81487

File Name: bind9_9102_rc2.nasl

Version: 1.10

Type: remote

Family: DNS

Published: 2015/02/24

Updated: 2018/11/15

Dependencies: 10028

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:isc:bind

Required KB Items: bind/version, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/02/18

Vulnerability Publication Date: 2014/12/08

Reference Information

CVE: CVE-2014-8500, CVE-2014-8680, CVE-2015-1349

BID: 71590, 72673, 73191