IBM WebSphere Application Server 8.0 < Fix Pack 10 Multiple Vulnerabilities (POODLE)

High Nessus Plugin ID 81401


The remote application server is affected by multiple vulnerabilities.


The remote host is running IBM WebSphere Application Server version 8.0 prior to Fix Pack 10. It is, therefore, affected by the following vulnerabilities :

- Multiple errors exist related to the included IBM HTTP server that can allow remote code execution or denial of service. (CVE-2013-5704, CVE-2014-0118, CVE-2014-0226, CVE-2014-0231 / PI22070)

- An error exists related to the implementation of the Elliptic Curve Digital Signature Algorithm (ECDSA) that could allow nonce disclosure via the 'FLUSH+RELOAD' cache side-channel attack. (CVE-2014-0076 / PI19700)

- An unspecified error exists related to HTTP headers that can allow information disclosure. (CVE-2014-3021 / PI08268)

- An unspecified error caused by improper account creation with the Virtual Member Manager SPI Admin Task 'addFileRegistryAccount' can allow remote attackers to bypass security restrictions. (CVE-2014-3070 / PI16765)

- An information disclosure vulnerability exists due to a failure to restrict access to resources located within the web application. A remote attacker can exploit this to obtain configuration data and other sensitive information. (CVE-2014-3083 / PI17768, PI30579 )

- A man-in-the-middle (MitM) information disclosure vulnerability known as POODLE. The vulnerability is due to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode. MitM attackers can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections. (CVE-2014-3566 / PI28435, PI28436, PI28437)

- An unspecified flaw in the Load Balancer for IPv4 Dispatcher component allows a remote attacker to cause a denial of service. (CVE-2014-4764 / PI21189)

- An unspecified input validation error exists related to the administrative console that can allow cross-site scripting and cross-site request forgery attacks.
(CVE-2014-4770, CVE-2014-4816 / PI23055)

- An error exists related to the Communications Enabled Applications (CEA) service that can allow XML External Entity Injection (XXE) attacks leading to information disclosure. This only occurs if CEA is enabled, and by default this is disabled. (CVE-2014-6166 / PI25310)

- An input validation error exists related to session input using URL rewriting that can allow cross-site scripting attacks. (CVE-2014-6167 / PI23819)

- An error exists related to the administrative console that can allow click-jacking attacks. (CVE-2014-6174 / PI27152)


Apply Fix Pack 10 for version 8.0 ( or later.

See Also

Plugin Details

Severity: High

ID: 81401

File Name: websphere_8_0_0_10.nasl

Version: $Revision: 1.8 $

Type: remote

Family: Web Servers

Published: 2015/02/18

Modified: 2016/05/24

Dependencies: 57034

Risk Information

Risk Factor: High


Base Score: 7.1

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:websphere_application_server

Required KB Items: www/WebSphere

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/02/16

Vulnerability Publication Date: 2014/05/01

Reference Information

CVE: CVE-2013-5704, CVE-2014-0076, CVE-2014-0118, CVE-2014-0226, CVE-2014-0231, CVE-2014-3021, CVE-2014-3070, CVE-2014-3083, CVE-2014-3566, CVE-2014-4764, CVE-2014-4770, CVE-2014-4816, CVE-2014-6166, CVE-2014-6167, CVE-2014-6174

BID: 66363, 66550, 68678, 68742, 68745, 69296, 69298, 69301, 69980, 69981, 70239, 70574, 70582, 71836, 71850

OSVDB: 104810, 105190, 109216, 109231, 109234, 110185, 110186, 110187, 111737, 111738, 113153, 113251, 116077, 116078, 116079

CERT: 577193