SuSE 11.3 Security Update : clamav (SAT Patch Number 10283)

High Nessus Plugin ID 81389

Synopsis

The remote SuSE 11 host is missing a security update.

Description

clamav was updated to version 0.98.6 to fix four security issues.

These security issues have been fixed :

- ClamAV allowed remote attackers to have unspecified impact via a crafted upx packer file, related to a heap out of bounds condition. (bnc#916214). (CVE-2015-1462)

- ClamAV allowed remote attackers to cause a denial of service (crash) via a crafted petite packer file, related to an incorrect compiler optimization.
(bnc#916215). (CVE-2015-1463)

- ClamAV allowed remote attackers to have unspecified impact via a crafted upack packer file, related to a heap out of bounds condition. (bnc#915512).
(CVE-2014-9328)

- ClamAV allowed remote attackers to have unspecified impact via a crafted (1) Yoda's crypter or (2) mew packer file, related to a heap out of bounds condition.
(bnc#916217). (CVE-2015-1461)

Solution

Apply SAT patch number 10283.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=915512

https://bugzilla.novell.com/show_bug.cgi?id=916214

https://bugzilla.novell.com/show_bug.cgi?id=916215

https://bugzilla.novell.com/show_bug.cgi?id=916217

http://support.novell.com/security/cve/CVE-2014-9328.html

http://support.novell.com/security/cve/CVE-2015-1461.html

http://support.novell.com/security/cve/CVE-2015-1462.html

http://support.novell.com/security/cve/CVE-2015-1463.html

Plugin Details

Severity: High

ID: 81389

File Name: suse_11_clamav-150206.nasl

Version: Revision: 1.1

Type: local

Agent: unix

Published: 2015/02/17

Updated: 2015/02/17

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:clamav, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2015/02/06

Reference Information

CVE: CVE-2014-9328, CVE-2015-1461, CVE-2015-1462, CVE-2015-1463