FreeBSD : apache24 -- several vulnerabilities (5804b9d4-a959-11e4-9363-20cf30e32f6d)

Medium Nessus Plugin ID 81116


The remote FreeBSD host is missing a security-related update.


Apache HTTP SERVER PROJECT reports : mod_proxy_fcgi: Fix a potential crash due to buffer over-read, with response headers' size above 8K.

mod_cache: Avoid a crash when Content-Type has an empty value. PR 56924.

mod_lua: Fix handling of the Require line when a LuaAuthzProvider is used in multiple Require directives with different arguments. PR57204.

core: HTTP trailers could be used to replace HTTP headers late during request processing, potentially undoing or otherwise confusing modules that examined or modified request headers earlier. Adds 'MergeTrailers' directive to restore legacy behavior.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 81116

File Name: freebsd_pkg_5804b9d4a95911e4936320cf30e32f6d.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2015/02/02

Modified: 2015/07/26

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:apache24, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/01/31

Vulnerability Publication Date: 2015/01/29

Reference Information

CVE: CVE-2013-5704, CVE-2014-3581, CVE-2014-3583, CVE-2014-8109