SuSE 11.3 Security Update : Ruby (SAT Patch Number 10126)

Medium Nessus Plugin ID 81040

Synopsis

The remote SuSE 11 host is missing one or more security updates.

Description

The Ruby script interpreter has been updated to fix two denial of service attacks when expanding XML. (CVE-2014-8080 / CVE-2014-8090)

Solution

Apply SAT patch number 10126.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=902851

https://bugzilla.novell.com/show_bug.cgi?id=905326

http://support.novell.com/security/cve/CVE-2014-8080.html

http://support.novell.com/security/cve/CVE-2014-8090.html

Plugin Details

Severity: Medium

ID: 81040

File Name: suse_11_ruby-141230.nasl

Version: Revision: 1.3

Type: local

Agent: unix

Published: 2015/01/27

Updated: 2015/10/05

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:ruby, p-cpe:/a:novell:suse_linux:11:ruby-doc-html, p-cpe:/a:novell:suse_linux:11:ruby-tk, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2014/12/30

Reference Information

CVE: CVE-2014-8080, CVE-2014-8090