openSUSE Security Update : gnu-efi / pesign / shim (openSUSE-2015-48)

High Nessus Plugin ID 80926


The remote openSUSE host is missing a security update.


shim was updated to fix several security issues.

- OOB read access when parsing DHCPv6 packets (remote DoS) (CVE-2014-3675).

- Heap overflow when parsing IPv6 addresses provided by tftp:// DHCPv6 boot option (RCE) (CVE-2014-3676).

- Memory corruption when processing user provided MOK lists (CVE-2014-3677).

More information is available at

To enable this update gnu-efi was updated to 3.0u and pesign to version 0.109


Update the affected gnu-efi / pesign / shim packages.

See Also

Plugin Details

Severity: High

ID: 80926

File Name: openSUSE-2015-48.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2015/01/23

Modified: 2015/01/23

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gnu-efi, p-cpe:/a:novell:opensuse:pesign, p-cpe:/a:novell:opensuse:pesign-debuginfo, p-cpe:/a:novell:opensuse:pesign-debugsource, p-cpe:/a:novell:opensuse:shim, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/01/20

Reference Information

CVE: CVE-2014-3675, CVE-2014-3676, CVE-2014-3677