Oracle Solaris Third-Party Patch Update : rubygems (cve_2012_2125_https_to)

Medium Nessus Plugin ID 80759

Synopsis

The remote Solaris system is missing a security patch for third-party software.

Description

The remote Solaris system is missing necessary patches to address security updates :

- RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack. (CVE-2012-2125)

- RubyGems before 1.8.23 does not verify an SSL certificate, which allows remote attackers to modify a gem during installation via a man-in-the-middle attack.
(CVE-2012-2126)

Solution

Upgrade to Solaris 11.1.21.4.1.

See Also

http://www.nessus.org/u?4a913f44

https://blogs.oracle.com/sunsecurity/cve-2012-2125-https-to-http-redirection-vulnerability-in-rubygems

http://www.nessus.org/u?5d4ec26e

Plugin Details

Severity: Medium

ID: 80759

File Name: solaris11_rubygems_20140715.nasl

Version: 1.2

Type: local

Published: 2015/01/19

Updated: 2018/11/15

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Vulnerability Information

CPE: cpe:/o:oracle:solaris:11.1, p-cpe:/a:oracle:solaris:rubygems

Required KB Items: Host/local_checks_enabled, Host/Solaris11/release, Host/Solaris11/pkg-list

Patch Publication Date: 2014/07/15

Reference Information

CVE: CVE-2012-2125, CVE-2012-2126