Oracle Solaris Third-Party Patch Update : perl-58 (cve_2013_1667_denial_of)

High Nessus Plugin ID 80729

Synopsis

The remote Solaris system is missing a security patch for third-party software.

Description

The remote Solaris system is missing necessary patches to address security updates :

- The rehash mechanism in Perl 5.8.2 through 5.16.x allows context-dependent attackers to cause a denial of service (memory consumption and crash) via a crafted hash key.
(CVE-2013-1667)

Solution

Upgrade to Solaris 11.1.7.5.0.

See Also

http://www.nessus.org/u?4a913f44

https://blogs.oracle.com/sunsecurity/cve-2013-1667-denial-of-service-dos-vulnerability-in-perl-58

Plugin Details

Severity: High

ID: 80729

File Name: solaris11_perl-58_20130521.nasl

Version: 1.2

Type: local

Published: 2015/01/19

Updated: 2018/11/15

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:oracle:solaris:11.1, p-cpe:/a:oracle:solaris:perl-58

Required KB Items: Host/local_checks_enabled, Host/Solaris11/release, Host/Solaris11/pkg-list

Patch Publication Date: 2013/05/21

Reference Information

CVE: CVE-2013-1667