Oracle Solaris Third-Party Patch Update : memcached (cve_2013_0179_buffer_errors)

Low Nessus Plugin ID 80703


The remote Solaris system is missing a security patch for third-party software.


The remote Solaris system is missing necessary patches to address security updates :

- The process_bin_delete function in memcached.c in memcached 1.4.4 and other versions before 1.4.17, when running in verbose mode, allows remote attackers to cause a denial of service (segmentation fault) via a request to delete a key, which does not account for the lack of a null terminator in the key and triggers a buffer over-read when printing to stderr.


Upgrade to Solaris 11.2.

See Also

Plugin Details

Severity: Low

ID: 80703

File Name: solaris11_memcached_20140731.nasl

Version: $Revision: 1.1 $

Type: local

Published: 2015/01/19

Modified: 2015/01/19

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 1.8

Vector: CVSS2#AV:A/AC:H/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: cpe:/o:oracle:solaris:11.2, p-cpe:/a:oracle:solaris:memcached

Required KB Items: Host/local_checks_enabled, Host/Solaris11/release, Host/Solaris11/pkg-list

Patch Publication Date: 2014/07/31

Reference Information

CVE: CVE-2013-0179