Oracle Solaris Third-Party Patch Update : gegl (multiple_integer_overflow_vulnerabilities_in)

High Nessus Plugin ID 80617


The remote Solaris system is missing a security patch for third-party software.


The remote Solaris system is missing necessary patches to address security updates :

- Multiple integer overflows in operations/external/ppm-load.c in GEGL (Generic Graphics Library) 0.2.0 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a large (1) width or (2) height value in a Portable Pixel Map (ppm) image, which triggers a heap-based buffer overflow. (CVE-2012-4433)


Upgrade to Solaris

See Also

Plugin Details

Severity: High

ID: 80617

File Name: solaris11_gegl_20130716.nasl

Version: $Revision: 1.1 $

Type: local

Published: 2015/01/19

Modified: 2015/01/19

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:oracle:solaris:11.1, p-cpe:/a:oracle:solaris:gegl

Required KB Items: Host/local_checks_enabled, Host/Solaris11/release, Host/Solaris11/pkg-list

Patch Publication Date: 2013/07/16

Reference Information

CVE: CVE-2012-4433