openSUSE Security Update : libssh (openSUSE-SU-2015:0017-1)

Medium Nessus Plugin ID 80438


The remote openSUSE host is missing a security update.


This update fixed the following security issue :

- Fix CVE-2014-8132: Double free on dangling pointers in initial key exchange packet; (bsc#910790).


Update the affected libssh packages.

See Also

Plugin Details

Severity: Medium

ID: 80438

File Name: openSUSE-2015-7.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2015/01/09

Modified: 2015/01/09

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libssh-debugsource, p-cpe:/a:novell:opensuse:libssh-devel, p-cpe:/a:novell:opensuse:libssh4, p-cpe:/a:novell:opensuse:libssh4-32bit, p-cpe:/a:novell:opensuse:libssh4-debuginfo, p-cpe:/a:novell:opensuse:libssh4-debuginfo-32bit, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/12/23

Reference Information

CVE: CVE-2014-8132