IBM WebSphere Application Server 8.5 < Fix Pack 18.104.22.168 Multiple Vulnerabilities (POODLE)
High Nessus Plugin ID 80398
SynopsisThe remote application server is affected by multiple vulnerabilities.
DescriptionThe IBM WebSphere Application Server running on the remote host is version 8.5 prior to Fix Pack 22.214.171.124. It is, therefore, affected by the following vulnerabilities :
- Multiple errors exist related to the included IBM HTTP server that can allow remote code execution or denial of service. (CVE-2013-5704, CVE-2014-0118, CVE-2014-0226, CVE-2014-0231 / PI22070)
- An unspecified error exists related to HTTP headers that can allow information disclosure. (CVE-2014-3021 / PI08268)
- An error exists related to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode. A man-in-the-middle attacker can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections. This is also known as the 'POODLE' issue. (CVE-2014-3566 / PI28435, PI28436, PI28437)
- An unspecified input validation errors exist related to the administrative console that can allow cross-site scripting and cross-site request forgery attacks.
(CVE-2014-4770, CVE-2014-4816 / PI23055)
- An unspecified error exists that can allow OpenID and OpenID Connect cookies to be spoofed, allowing information disclosure. (CVE-2014-6164 / PI23430)
- An error exists related to the Communications Enabled Applications (CEA) service that can allow XML External Entity Injection (XXE) attacks leading to information disclosure. This only occurs if CEA is enabled. By default this is disabled. (CVE-2014-6166 / PI25310)
- An input validation error exists related to session input using URL rewriting that can allow cross-site scripting attacks. (CVE-2014-6167 / PI23819)
- An error exists related to the administrative console that can allow 'click-jacking' attacks. (CVE-2014-6174 / PI27152)
- An error exists related to deployment descriptor security constraints and ServletSecurity annotations on a servlet that can allow privilege escalation. Note that this issue only affects the 'Liberty Profile'.
(CVE-2014-8890 / PI29911)
SolutionApply Fix Pack 4 for (126.96.36.199) or later.
Note that the following Interim Fixes are available :
- CVE-2013-5704, CVE-2014-0118, CVE-2014-0226, and CVE-2014-0231 are corrected in IF PI22070.
- CVE-2014-3566 is corrected in various IFs.
Consult IBM document 'swg21687173' for details.
- CVE-2014-4770 and CVE-2014-4816 are corrected in IF PI23055.
- CVE-2014-6166 is corrected in IF PI25310.
- CVE-2014-8890 is corrected in IF PI29911.