IBM WebSphere Application Server 8.5 < Fix Pack Multiple Vulnerabilities (POODLE)

medium Nessus Plugin ID 80398
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 6.7


The remote application server is affected by multiple vulnerabilities.


The IBM WebSphere Application Server running on the remote host is version 8.5 prior to Fix Pack It is, therefore, affected by the following vulnerabilities :

- Multiple errors exist related to the included IBM HTTP server that can allow remote code execution or denial of service. (CVE-2013-5704, CVE-2014-0118, CVE-2014-0226, CVE-2014-0231 / PI22070)

- An unspecified error exists related to HTTP headers that can allow information disclosure. (CVE-2014-3021 / PI08268)

- An error exists related to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode. A man-in-the-middle attacker can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections. This is also known as the 'POODLE' issue. (CVE-2014-3566 / PI28435, PI28436, PI28437)

- An unspecified input validation errors exist related to the administrative console that can allow cross-site scripting and cross-site request forgery attacks.
(CVE-2014-4770, CVE-2014-4816 / PI23055)

- An unspecified error exists that can allow OpenID and OpenID Connect cookies to be spoofed, allowing information disclosure. (CVE-2014-6164 / PI23430)

- An error exists related to the Communications Enabled Applications (CEA) service that can allow XML External Entity Injection (XXE) attacks leading to information disclosure. This only occurs if CEA is enabled. By default this is disabled. (CVE-2014-6166 / PI25310)

- An input validation error exists related to session input using URL rewriting that can allow cross-site scripting attacks. (CVE-2014-6167 / PI23819)

- An error exists related to the administrative console that can allow 'click-jacking' attacks. (CVE-2014-6174 / PI27152)

- An error exists related to deployment descriptor security constraints and ServletSecurity annotations on a servlet that can allow privilege escalation. Note that this issue only affects the 'Liberty Profile'.
(CVE-2014-8890 / PI29911)


Apply Fix Pack 4 for ( or later.

Note that the following Interim Fixes are available :

- CVE-2013-5704, CVE-2014-0118, CVE-2014-0226, and CVE-2014-0231 are corrected in IF PI22070.

- CVE-2014-3566 is corrected in various IFs.
Consult IBM document 'swg21687173' for details.

- CVE-2014-4770 and CVE-2014-4816 are corrected in IF PI23055.

- CVE-2014-6166 is corrected in IF PI25310.

- CVE-2014-8890 is corrected in IF PI29911.

See Also

Plugin Details

Severity: Medium

ID: 80398

File Name: websphere_8_5_5_4.nasl

Version: 1.16

Type: remote

Family: Web Servers

Published: 1/7/2015

Updated: 11/25/2019

Dependencies: websphere_detect.nasl

Risk Information

Risk Factor: Medium

VPR Score: 6.7

CVSS Score Source: CVE-2014-0226

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:websphere_application_server

Required KB Items: www/WebSphere

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/8/2014

Vulnerability Publication Date: 3/29/2014

Reference Information

CVE: CVE-2013-5704, CVE-2014-0118, CVE-2014-0226, CVE-2014-0231, CVE-2014-3021, CVE-2014-3566, CVE-2014-4770, CVE-2014-4816, CVE-2014-6164, CVE-2014-6166, CVE-2014-6167, CVE-2014-6174, CVE-2014-8890

BID: 66550, 68678, 68742, 68745, 69980, 69981, 70239, 70574, 70582, 71834, 71836, 71837, 71850

CERT: 577193

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990