FreeBSD : png -- heap overflow for 32-bit builds (c564f9bd-8ba7-11e4-801f-0022156e8794)

High Nessus Plugin ID 80352


The remote FreeBSD host is missing one or more security-related updates.


32-bit builds of PNG library are vulnerable to an unsigned integer overflow that is triggered by a crafted wide interlaced images.
Overflow results in a heap corruption that will crash the application and may lead to the controlled overwrite of a selected portions of process address space.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 80352

File Name: freebsd_pkg_c564f9bd8ba711e4801f0022156e8794.nasl

Version: $Revision: 1.1 $

Type: local

Published: 2015/01/05

Modified: 2015/01/05

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:png, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2015/01/05

Vulnerability Publication Date: 2014/12/23