LibreOffice 4.x < 4.2.7 Impress Remote RCE

High Nessus Plugin ID 80079


The remote host contains an application that is affected by a use-after-free memory vulnerability.


A version of LibreOffice is installed on the remote Windows host that is 4.x prior to 4.2.7. It is, therefore, affected by a use-after-free vulnerability related to the Impress Remote socket manager that allows denial of service attacks or arbitrary code execution by means of a specially crafted TCP request that causes already freed memory to be dereferenced.

Note that Nessus has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.


Upgrade to LibreOffice version 4.2.7 ( or later.

See Also

Plugin Details

Severity: High

ID: 80079

File Name: libreoffice_427.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2014/12/17

Modified: 2016/11/23

Dependencies: 55573

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:libreoffice:libreoffice

Required KB Items: installed_sw/LibreOffice, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/10/18

Vulnerability Publication Date: 2014/11/05

Reference Information

CVE: CVE-2014-3693

BID: 71351

OSVDB: 114326