Mandriva Linux Security Advisory : openafs (MDVSA-2014:244)

High Nessus Plugin ID 79989


The remote Mandriva Linux host is missing one or more security updates.


Multiple vulnerabilities has been found and corrected in openafs :

Buffer overflow in certain client utilities in OpenAFS before 1.6.2 allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via a long fileserver ACL entry (CVE-2013-1794).

Integer overflow in ptserver in OpenAFS before 1.6.2 allows remote attackers to cause a denial of service (crash) via a large list from the IdToName RPC, which triggers a heap-based buffer overflow (CVE-2013-1795).

OpenAFS before 1.4.15, 1.6.x before 1.6.5, and 1.7.x before 1.7.26 uses weak encryption (DES) for Kerberos keys, which makes it easier for remote attackers to obtain the service key (CVE-2013-4134).

The vos command in OpenAFS 1.6.x before 1.6.5, when using the -encrypt option, only enables integrity protection and sends data in cleartext, which allows remote attackers to obtain sensitive information by sniffing the network (CVE-2013-4135).

Buffer overflow in the GetStatistics64 remote procedure call (RPC) in OpenAFS 1.4.8 before 1.6.7 allows remote attackers to cause a denial of service (crash) via a crafted statsVersion argument (CVE-2014-0159).

A denial of service flaw was found in libxml2, a library providing support to read, modify and write XML and HTML files. A remote attacker could provide a specially crafted XML file that, when processed by an application using libxml2, would lead to excessive CPU consumption (denial of service) based on excessive entity substitutions, even if entity substitution was disabled, which is the parser default behavior (CVE-2014-3660).

The updated packages have been upgraded to the 1.4.15 version and patched to correct these issues.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 79989

File Name: mandriva_MDVSA-2014-244.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2014/12/15

Modified: 2014/12/16

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:dkms-libafs, p-cpe:/a:mandriva:linux:lib64openafs-devel, p-cpe:/a:mandriva:linux:lib64openafs1, p-cpe:/a:mandriva:linux:openafs, p-cpe:/a:mandriva:linux:openafs-client, p-cpe:/a:mandriva:linux:openafs-doc, p-cpe:/a:mandriva:linux:openafs-server, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/12/14

Reference Information

CVE: CVE-2013-1794, CVE-2013-1795, CVE-2013-4134, CVE-2013-4135, CVE-2014-0159

BID: 58299, 58300, 61438, 61439, 66776

MDVSA: 2014:244