Debian DSA-3095-1 : xorg-server - security update

Medium Nessus Plugin ID 79882

Synopsis

The remote Debian host is missing a security-related update.

Description

Ilja van Sprundel of IOActive discovered several security issues in the X.org X server, which may lead to privilege escalation or denial of service.

Solution

Upgrade the xorg-server packages.

For the stable distribution (wheezy), these problems have been fixed in version 1.12.4-6+deb7u5.

For the upcoming stable distribution (jessie), these problems will be fixed soon.

See Also

https://packages.debian.org/source/wheezy/xorg-server

https://www.debian.org/security/2014/dsa-3095

Plugin Details

Severity: Medium

ID: 79882

File Name: debian_DSA-3095.nasl

Version: 1.8

Type: local

Agent: unix

Published: 2014/12/15

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:xorg-server, cpe:/o:debian:debian_linux:7.0

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/12/10

Reference Information

CVE: CVE-2014-8091, CVE-2014-8092, CVE-2014-8093, CVE-2014-8094, CVE-2014-8095, CVE-2014-8096, CVE-2014-8097, CVE-2014-8098, CVE-2014-8099, CVE-2014-8100, CVE-2014-8101, CVE-2014-8102

BID: 71595, 71596, 71597, 71598, 71599, 71600, 71601, 71602, 71604, 71605, 71606, 71608

DSA: 3095