MariaDB 5.5 < 5.5.37 Multiple Vulnerabilities

medium Nessus Plugin ID 79826
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MariaDB 5.5 running on the remote host is a version prior to 5.5.37. It is, therefore, potentially affected by vulnerabilities due to errors related to the following components :

- Client
- Options
- Performance Schema
- RBR

Solution

Upgrade to MariaDB 5.5.37 or later or apply the vendor patch.

See Also

https://mariadb.com/kb/en/library/mariadb-5537-changelog/

http://www.nessus.org/u?4e66ff27

Plugin Details

Severity: Medium

ID: 79826

File Name: mariadb_5_5_37.nasl

Version: 1.6

Type: remote

Family: Databases

Published: 12/9/2014

Updated: 11/25/2019

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2014-2436

VPR

Risk Factor: Medium

Score: 5.5

CVSS v2

Risk Factor: Medium

Base Score: 6

Temporal Score: 4.4

Vector: AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 4/17/2014

Vulnerability Publication Date: 1/28/2014

Reference Information

CVE: CVE-2014-2430, CVE-2014-2431, CVE-2014-2436, CVE-2014-2440

BID: 66850, 66858, 66890, 66896