MariaDB 5.5 < 5.5.37 Multiple Vulnerabilities

medium Nessus Plugin ID 79826


The remote database server is affected by multiple vulnerabilities.


The version of MariaDB 5.5 running on the remote host is a version prior to 5.5.37. It is, therefore, potentially affected by vulnerabilities due to errors related to the following components :

- Client
- Options
- Performance Schema


Upgrade to MariaDB 5.5.37 or later or apply the vendor patch.

See Also

Plugin Details

Severity: Medium

ID: 79826

File Name: mariadb_5_5_37.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 12/9/2014

Updated: 11/18/2022

Configuration: Enable paranoid mode

Supported Sensors: Frictionless Assessment Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 5.5


Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS Score Source: CVE-2014-2436


Risk Factor: Medium

Base Score: 4.9

Temporal Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS Score Source: CVE-2019-2481

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 4/17/2014

Vulnerability Publication Date: 1/28/2014

Reference Information

CVE: CVE-2014-2430, CVE-2014-2431, CVE-2014-2436, CVE-2014-2440, CVE-2019-2481

BID: 66850, 66858, 66890, 66896