openSUSE Security Update : ruby19 (openSUSE-SU-2014:1589-1)

Medium Nessus Plugin ID 79820


The remote openSUSE host is missing a security update.


ruby19 was updated to fix two security issues.

These security issues were fixed :

- Denial Of Service XML Expansion (CVE-2014-8080).

- Denial Of Service XML Expansion (CVE-2014-8090).

Note: These are two separate issues.


Update the affected ruby19 packages.

See Also

Plugin Details

Severity: Medium

ID: 79820

File Name: openSUSE-2014-758.nasl

Version: $Revision: 1.3 $

Type: local

Agent: unix

Published: 2014/12/09

Modified: 2015/10/05

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ruby19, p-cpe:/a:novell:opensuse:ruby19-debuginfo, p-cpe:/a:novell:opensuse:ruby19-debugsource, p-cpe:/a:novell:opensuse:ruby19-devel, p-cpe:/a:novell:opensuse:ruby19-devel-extra, p-cpe:/a:novell:opensuse:ruby19-doc-ri, p-cpe:/a:novell:opensuse:ruby19-tk, p-cpe:/a:novell:opensuse:ruby19-tk-debuginfo, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/11/28

Reference Information

CVE: CVE-2014-8080, CVE-2014-8090