openSUSE Security Update : rubygem-actionpack-3_2 (openSUSE-SU-2014:1515-1)

Medium Nessus Plugin ID 79617


The remote openSUSE host is missing a security update.


rubygem-actionpack-3_2 was updated to fix two security issues.

These security issues were fixed :

- Arbitrary file existence disclosure (CVE-2014-7829).

- Arbitrary file existence disclosure (CVE-2014-7818).


Update the affected rubygem-actionpack-3_2 package.

See Also

Plugin Details

Severity: Medium

ID: 79617

File Name: openSUSE-2014-724.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/11/28

Modified: 2014/11/28

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:rubygem-actionpack-3_2, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/11/20

Reference Information

CVE: CVE-2014-7818, CVE-2014-7829