FreeBSD : flac -- Multiple vulnerabilities (a33addf6-74e6-11e4-a615-f8b156b6dcc8)

High Nessus Plugin ID 79567


The remote FreeBSD host is missing one or more security-related updates.


Erik de Castro Lopo reports :

Google Security Team member, Michele Spagnuolo, recently found two potential problems in the FLAC code base. They are :

- CVE-2014-9028: Heap buffer write overflow.

- CVE-2014-8962: Heap buffer read overflow.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 79567

File Name: freebsd_pkg_a33addf674e611e4a615f8b156b6dcc8.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2014/11/26

Modified: 2015/07/16

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:flac, p-cpe:/a:freebsd:freebsd:linux-c6-flac, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2014/11/25

Vulnerability Publication Date: 2014/11/25

Reference Information

CVE: CVE-2014-8962, CVE-2014-9028