QuickTime < 7.7.6 Multiple Vulnerabilities (Windows)

High Nessus Plugin ID 78678

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9

Synopsis

The remote Windows host contains an application that is affected by multiple vulnerabilities.

Description

The version of Apple QuickTime installed on the remote Windows host is prior to 7.7.6. It is, therefore, affected by the following vulnerabilities :

- A memory corruption flaw exists when handling specially crafted RLE encoded videos due to user-supplied input not being properly sanitized. (CVE-2014-1391)

- A buffer overflow flaw exists when parsing specially crafted MIDI files due to user-supplied input not being properly validated. (CVE-2014-4350)

- A buffer overflow flaw exists when parsing specially crafted M4A files due to user-supplied input not being properly validated. (CVE-2014-4351)

- A memory corruption flaw exists in the mvhd atom when handling malformed version numbers and flags due to not properly sanitizing user-supplied input. (CVE-2014-4979)

Successful exploitation of these issues by a remote attacker can result in program termination or arbitrary code execution, subject to the user's privileges.

Solution

Upgrade to QuickTime 7.7.6 or later.

See Also

https://support.apple.com/en-us/HT203092

https://www.securityfocus.com/archive/1/533790/30/0/threaded

Plugin Details

Severity: High

ID: 78678

File Name: quicktime_776.nasl

Version: 1.6

Type: local

Agent: windows

Family: Windows

Published: 2014/10/24

Updated: 2018/11/15

Dependencies: 21561

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:quicktime

Required KB Items: SMB/QuickTime/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/10/22

Vulnerability Publication Date: 2014/07/23

Reference Information

CVE: CVE-2014-1391, CVE-2014-4350, CVE-2014-4351, CVE-2014-4979

BID: 68852, 69907, 69908, 70643

APPLE-SA: APPLE-SA-2014-10-22-1