Debian DSA-3054-1 : mysql-5.5 - security update

High Nessus Plugin ID 78589

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.8

Synopsis

The remote Debian host is missing a security-related update.

Description

Several issues have been discovered in the MySQL database server. The vulnerabilities are addressed by upgrading MySQL to the new upstream version 5.5.40. Please see the MySQL 5.5 Release Notes and Oracle's Critical Patch Update advisory for further details :

- https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5
-39.html
- https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5
-40.html

- http://www.oracle.com/technetwork/topics/security/cpuoct 2014-1972960.html

Solution

Upgrade the mysql-5.5 packages.

For the stable distribution (wheezy), these problems have been fixed in version 5.5.40-0+wheezy1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=765663

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-39.html

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-40.html

http://www.nessus.org/u?1ada40cc

https://packages.debian.org/source/wheezy/mysql-5.5

https://www.debian.org/security/2014/dsa-3054

Plugin Details

Severity: High

ID: 78589

File Name: debian_DSA-3054.nasl

Version: 1.12

Type: local

Agent: unix

Published: 2014/10/21

Updated: 2020/03/12

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 5.8

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:mysql-5.5, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/10/20

Vulnerability Publication Date: 2012/12/03

Reference Information

CVE: CVE-2012-5615, CVE-2014-4274, CVE-2014-4287, CVE-2014-6463, CVE-2014-6464, CVE-2014-6469, CVE-2014-6478, CVE-2014-6484, CVE-2014-6491, CVE-2014-6494, CVE-2014-6495, CVE-2014-6496, CVE-2014-6500, CVE-2014-6505, CVE-2014-6507, CVE-2014-6520, CVE-2014-6530, CVE-2014-6551, CVE-2014-6555, CVE-2014-6559

BID: 56766, 69732, 70444, 70446, 70451, 70455, 70462, 70469, 70478, 70486, 70487, 70489, 70496, 70497, 70510, 70516, 70517, 70530, 70532, 70550

DSA: 3054