Oracle Linux 6 / 7 : Unbreakable Enterprise kernel (ELSA-2014-3081)

High Nessus Plugin ID 78578

Synopsis

The remote Oracle Linux host is missing one or more security updates.

Description

Description of changes:

kernel-uek [3.8.13-44.1.3.el7uek]
- ALSA: control: Don't access controls outside of protected regions (Lars-Peter Clausen) [Orabug: 19817785] {CVE-2014-4653} {CVE-2014-4654} {CVE-2014-4655}
- ALSA: control: Fix replacing user controls (Lars-Peter Clausen) [Orabug: 19817747] {CVE-2014-4653} {CVE-2014-4654} {CVE-2014-4655}
- kvm: iommu: fix the third parameter of kvm_iommu_put_pages (CVE-2014-3601) (Michael S. Tsirkin) [Orabug: 19817646] {CVE-2014-3601}
- net: sctp: inherit auth_capable on INIT collisions (Daniel Borkmann) [Orabug: 19816067] {CVE-2014-5077}

[3.8.13-44.1.2.el7uek]
- CVE-2014-3535: NULL pointer dereference in VxLAN packet logging. (Sasha Levin) [Orabug: 19613139]

Solution

Update the affected unbreakable enterprise kernel packages.

See Also

https://oss.oracle.com/pipermail/el-errata/2014-October/004545.html

https://oss.oracle.com/pipermail/el-errata/2014-October/004546.html

Plugin Details

Severity: High

ID: 78578

File Name: oraclelinux_ELSA-2014-3081.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2014/10/20

Updated: 2019/04/01

Dependencies: 122878, 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:dtrace-modules-3.8.13-44.1.3.el6uek, p-cpe:/a:oracle:linux:dtrace-modules-3.8.13-44.1.3.el7uek, p-cpe:/a:oracle:linux:kernel-uek, p-cpe:/a:oracle:linux:kernel-uek-debug, p-cpe:/a:oracle:linux:kernel-uek-debug-devel, p-cpe:/a:oracle:linux:kernel-uek-devel, p-cpe:/a:oracle:linux:kernel-uek-doc, p-cpe:/a:oracle:linux:kernel-uek-firmware, cpe:/o:oracle:linux:6, cpe:/o:oracle:linux:7

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/10/18

Vulnerability Publication Date: 2014/07/03

Reference Information

CVE: CVE-2014-3535, CVE-2014-3601, CVE-2014-4653, CVE-2014-4654, CVE-2014-4655, CVE-2014-5077

BID: 68162, 68164, 68881, 69489, 69721