openSUSE Security Update : srtp (openSUSE-SU-2014:1250-1)

Low Nessus Plugin ID 78020


The remote openSUSE host is missing a security update.


srtp was updated to fix a buffer overflow flaw that allowed remote attackers to cause a denial of service (crash) via vectors related to a length inconsistency in the crypto_policy_set_from_profile_for_rtp and srtp_protect functions. (CVE-2013-2139).


Update the affected srtp packages.

See Also

Plugin Details

Severity: Low

ID: 78020

File Name: openSUSE-2014-565.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/10/02

Modified: 2014/10/02

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libsrtp1, p-cpe:/a:novell:opensuse:libsrtp1-debuginfo, p-cpe:/a:novell:opensuse:srtp-debugsource, p-cpe:/a:novell:opensuse:srtp-devel, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/09/19

Reference Information

CVE: CVE-2013-2139