Squid 3.x < 3.3.13 / 3.4.7 Request Processing DoS

Medium Nessus Plugin ID 77985


The remote proxy server is affected by a denial of service vulnerability.


According to its banner, the version of Squid running on the remote host is 3.x prior to 3.3.13 or 3.4.7. It is, therefore, affected by a denial of service vulnerability.

The flaw exists due to user-supplied input not being properly validated in request parsing. This allows a remote attacker to specially craft a request with Range headers with unidentifiable byte-range values to crash the application.

Note that Nessus has relied only on the version in the proxy server's banner. The patch released to address the issue does not update the version in the banner. If the patch has been applied properly, and the service has been restarted, consider this to be a false positive.


Upgrade to Squid version 3.3.13 / 3.4.7 or later, or apply the vendor-supplied patch.

See Also




Plugin Details

Severity: Medium

ID: 77985

File Name: squid_3_4_7.nasl

Version: $Revision: 1.1 $

Type: remote

Family: Firewalls

Published: 2014/09/30

Modified: 2014/09/30

Dependencies: 49692

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: www/squid, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/08/28

Vulnerability Publication Date: 2014/08/28

Reference Information

CVE: CVE-2014-3609

BID: 69453

OSVDB: 110525